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Introduction 
This manual describes how to upload of language files and start-up bitmap in DC 6990 Conference Units 
using the FUU Firmware Upgrade Utility. 

 

Buttons and windows in the FUU  
 

  

 

 

                                                                    
 

 

 

 

 

 

 

 

  

’CU window’ 
Those windows shows 
’Type’, ’Serial number’ & 
’Firmware version’ (’PPC’ & 
’DSP’ version) of the CU. 

’Status window’ 
This window shows the 
status and give messages to 

  

’Upgrade CU firmware 
buttons’ 
Press those buttons to 
upgrade the firmware in the 
CU  ’U d  PPC’ & 

  

’Command line’ button 

Press this Icon to get a 
window for sending 
commands to the CU 

’Present Units window’ 
All units present in the 

     
 ’Selected Units window’ 

Unit, which are selected for 
upgrading are shown in this 

 
 

’Update status button’ 

Press this buttons to update 
the status of the units 
connected 

’Set Feature Id button’ 
Press this button change 
the Feature setting for the 
selected units 
 

’Upgrade Units button’ 
Press this button to 
upgrade the units 
present in the ’Selected 
U it  i d ’ 
 

“Select unit” buttons 
Select one of the units in the 
’Present Units window’ and 
press the ’Add unit button’ 
to add ’Selected Units 

  

’Remove buttons’ 
Press those buttons to either 
remove a selected unit or to 
remove all units from the 
’S l t d U it  i d ’  
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Preparing the system 

Before you start 
The following equipment is needed: 

• A PC with an LAN port 

• A Ethernet LAN cable  

• The DCS 6000 Firmware Upgrade Utility 
(FUU) 

• The DCS 6000 Firmware Library 

General guidelines 
Check that all communication in the system is 
stable before performing updates.  

IMPORTANT: NEVER REMOVE POWER FROM 
A SYSTEM PERFORMING AN UPDATE. 

Errors in the update procedure may render the 
units unusable, so do not update a system just 
before a critical meeting if you have no spare 
equipment.  

If for some reason the update fails for one or 
more units but power has not been removed it is 
usually possible to do the update again and units 
that did not correctly update the first time will 
continue where they stopped the second time 
around. 

Locked units 
If a unit displays the message “Locked” in the 
LCD display, then the firmware version in the 
unit is not compatible with the firmware in the 
Central Unit and the firmware in the unit has to 
be upgraded/downgraded. 

Firmware Upgrade Utility (FUU)  
The DCS 6000 ‘Firmware Upgrade Utility’ (FUU) is 
included in the Firmware Releases.  

IMPORTANT: Always use the latest version 
of the FUU. 
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Connecting the FUU – Firmware Upgrade Utility 
1. Unzip the zip file containing a 

Firmware Upgrade Library folder and 
a FUU folder to the desktop or 
another convenient location on the 
PC.  

 

2. Connect the PC to the CCU or CU 
61xx using a LAN cable and switch 
on the CU 6xxx. 

 

3. Browse to the folder 

‘DIS_Firmware_Upgrade_Utility_xxx’ 

And open the folder 

 

4. Start DIS Firmware Upgrade Utility 
(FUU) in the FUU folder by double-
clicking the icon. 

 

5. The FUU starts. 

The FUU application will 
automatically find the folders with 
the firmware releases and the 
language files. 

 

 
6. Select to use Ethernet connection. 

Check the Ethernet settings by 
selecting ‘Ethernet connection to 
CU/CCU’. 

Type the CU/CCU IP address in IP 
address field. Use IP port 3142. 
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7. The FUU will now show all units in 
the system as well as information 
about the CU. 

 

Checking the ‘Error Status’ window 
8. Before any languages upload is 

performed the ‘Error Status’ has to 
be checked. 

The error in the communication 
from the units to the CU/CCU can be 
checked clicking ‘View/View Error 
status Window’  

Basically this window shall show no 
errors in the system. However in 
large systems, there might be 
generated some errors during start-
up.  

The error counter can be reset by 
clicking ‘Reset error counters in CU’. 
After resetting the counters, no 
error must be present. If a counter 
is counting up, it is a clear 
indication, that there are 
communication errors.  

IMPORTANT: DON’T DO ANY 
UPLOAD IF THERE ARE ERRORS 
IN THE COMMUNICATION. 

If errors are present or for more test 
options, please refer to the manual 
‘Upgrade Manual DCS 6000’. 
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Create/edit languages for DC 6990 P 
There are two types of texts available on the DC 
6990 P: static text and dynamic text. The static 
text is all the fixed text or ‘labels’ on the buttons, 
menu headings and system messages that lie in 
the firmware. The dynamic text is all the text 
received from the SW 6000 either at system 
start-up or during the use of the system like 
conference names, agenda, delegate names, 
voting parameters etc.  

The following sections deal with creating, 
changing and deleting the static text while the 
very last section deals with enabling the dynamic 
text from the SW 6000. 

Quick guide 
To get started with the language setup first 
download and unzip the Firmware Release folder 
from the DIS web site. The folder contains three 
sub-folders; FUU, FUU_language_library and 
FUU_Library_Release. Do not rename any of the 
folders or files or move the files outside the 
designated folders as this may prevent the FUU 
from working.  

Open the FUU and upgrade the system to the 
latest firmware release.  

Upload the language files to the DC 6990 P units 
following the instructions in the section ‘Manage 
Languages in DC 6990’’  

Upload Language files and enable the languages 
on the units following the instructions in the 
section ‘Enable New Languages’. 

If the system is used with the SW6000, the 
dynamic text can be enabled following the 
instructions in the section ‘Enable Dynamic Text’. 

Factory labels 
DC 6990 P’s with Firmware Release 6.6 (or later) 
contain default (English) factory labels only. 
Upgrades from earlier releases to release 6.6 will 
remove all language files. 

To enable more languages on the units it is 
necessary to upload the required language files 
to the units using the FUU. A number of language 
files are freely available in the ‘Firmware Release’ 
folder. DIS does not take any responsibility for 
the accuracy of these language files, the 
compatibility with current/future versions or the 
availability of language files for new firmware 
releases. 

The default (English) factory labels cannot be 
deleted. To change the default (English) factory 
labels on the units, an English language file must 
be created and uploaded to the units. The English 
language file will subsequently overwrite the 
factory labels. If the English language file is later 
deleted, the units will display the factory 
(English) labels. 

Language files that are not fully translated will 
display the default (English) factory label where 
the translation is missing. 

 



 

 

Create new language file 
9. Open Library -> Edit Language 

Library. 

The library is empty when there 
are no language files available 
other than the factory labels on 
the DC 6990 P. 

Select the ‘New Translation File’ 
button. 

 
10. A pop-up window appears. 

 
11. Select a Language in the drop-

down ‘Language’ list and enter 
an optional comment in the 
‘Comment’ field. 

 

 

 

 

 

Press ‘Next’. 

 

12. Qt Linguist opens up. 

 

Note: If there is 
already a 
language file with 
the same 
LocaleID, the new 
language file will 
overwrite the 

  

 



 

 

13. Select the 
‘DisSetupMenuWidget’ label 
collection in the Context 
window. 

Select the first label ‘Unit Type’ 
in the Strings window. 

Enter the translation in the 
‘Language translation’ field in 
the window below. 

Use the Developer comments 
above the Language translation 
field to understand the label. 
Button texts should be kept as 
short as possible. 

There is no way to see if the 
translation is too long other 
than uploading the language to 
the DC 6990 P and visually 
inspect it. 

 

14. Press Ctrl + Return to mark the 
translation as done and 
continue to the next unfinished 
translation on the list. 

 
15. Translate all 32 labels. 

Select the ‘QObject’ label 
collection in the Context 
window and translate the 
remaining 127 labels. 

If there are any un-translated 
labels, the units will show the 
factory labels instead (English). 

 



 

 

16. Select File -> Save to save the 
translations or optionally press 
Ctrl + S. 

Do not save the file with 
another name or file extension. 
This will corrupt the file. 

Close Qt Linguist. 

 
17. Close the ‘FUU Language 

Library’ window. 

 

Edit language file 
18. Open Library -> Edit Language 

Library. 

Mark the translation file to be 
edited and select the ‘Edit 
Translation File’ button. 

 
19. A pop-up window appears. 

Press ‘Next’. 

 



 

 

20. Qt Linguist opens up. 

 
21. Select the label to edit in the 

Strings window. 

Change the translation in the 
‘Language translation’ field in 
the window below. 

Press Ctrl + Return to mark the 
translation as done. 

Select the next label to edit. 

Select File -> Save to save the 
translations or optionally press 
Ctrl + S. 

Close Qt Linguist. 

 
22. Close the ‘FUU Language 

Library’ window. 

 

Delete language file 
23. Open Library -> Edit Language 

Library. 

Mark the translation file to be 
deleted and select the ‘Delete 
Translation File’ button. 

Close the ‘FUU Language 
Library’ window. 

 



 

 

Import language file 
24. Open Library -> Edit Language 

Library. 

Select the ‘Import Translation 
Files’ button. 

 
25. A file browser window opens 

up. 

Browse for the file to import, 
select it and press ‘Open’. 

 
26. The imported file is now listed 

in the FUU Language Library. 

Close the ‘FUU Language 
Library’ window. 

 

 
 

Export language file 
27. Open Library -> Edit Language 

Library. 

Mark the translation file to be 
exported and select the ‘Export 
Translation File’ button. 

 



 

 

28. A file browser window opens 
up. 

Browse to the desired location 
and press ‘Save’. 

 
29. Close the ‘FUU Language 

Library’ window. 

 

View system language status 
30. The two status indicators to the 

left of the DIS logo shows the 
system firmware and language 
status.  

The Firmware Status field will 
display ‘OK’ if the firmware in 
all units is up to date and 
compatible. Otherwise it will 
display ‘Firmware Upgrade 
Needed’. 

The Language Status field will 
display ‘OK’ if all the language 
files available in the FUU are 
also available on the units. 
Otherwise it will display 
‘Language Upgrade Needed’. 
Any changes made to a 
language file after it has been 
uploaded to the units will not 
be seen in the Language Status 
field. It is therefore important 
to upload the edited language 
file to the units right after 
editing to make sure the latest 
version is on the units. 

 



 

 

Also please notice that the 
language status has no impact 
on the system performance. 
The system will always work 
independently of the language 
status. 

If a language upgrade is 
required, it is possible to get a 
system overview of the existing 
and missing language files in 
the ‘View Language status 
(DC69 units)’ menu. 

31. Open View -> View Language 
status (DC69 units). 

 
32. The ‘Languages on Units’ 

window displays the available 
languages in the Language 
column. 

If some language files have not 
been uploaded to the DC 6990 
P’s this will be indicated in the 
‘On all units’ and ‘Status’ 
columns. 

Close the ‘Languages on Units’ 
window. 

 

 

 

 

 

 

Note:  Any changes made to a 
language file after it has been 
uploaded to the units will not be seen 
in the Status column. It is therefore 
important to upload the edited 
language file to the units right after 
editing to make sure the latest version 
is on the units 



 

 

View unit language status 
33. The individual language status 

of the units can be seen in the 
Present Units list. All units that 
require a language upgrade are 
marked by ‘!’ in the Lang. Rel. 
ID column.  

Open the ‘Show unit status’ to 
see more details on the units’ 
individual language status. 

 
34. Mark a DC 6990 P unit on the 

unit list, right-click and select 
‘Show unit status’. 

 



 

 

35. A ‘unit status’ window appears 
indicating the available 
languages on the unit. 

If there are languages available 
in the FUU that are not 
uploaded to the unit this will be 
indicated by a ‘Language 
Update Required’ message. 

Close the ‘unit status’ window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Note:  Any changes made to a 
language file after it has been 
uploaded to the unit will not be 
registered with a ‘Language Update 
Required’ message. It is therefore 
important to upload the edited 
language file to the unit right after 

       
    

 



 

 

 

Manage languages on DC 6990 P 

Upload language file(s) 
36. Change the FUU to the 

Advanced FUU Layout in Setup 
-> Advanced FUU Layout. 

 
37. Extra buttons appears in the 

FUU. 

 



 

 

38. Select the DC 6990 P(s) on the 
unit list that requires a 
language upgrade by using the 
‘Select unit type’ or ‘Select unit’ 
button. 

Press ‘Upgrade Languages’. 

 
39. An ‘Upgrade Languages on 

Units’ window opens up. 

Select the ‘Send languages to 
DC69 units’ tab. 

 
40. Select the languages to upload 

by manually selecting them or 
select them all by using the 
‘Select All’ button. 

Press ‘Send Languages to Units’ 
to upload the selected 
languages. 

Please note that if a language 
file already exists on the units 
and a new language file for this 
language is sent to the units, 
the existing language file will be 
replaced by the new one. It is 
only possible to have one 
language file per language at a 
time.  

 



 

 

 
41. The FUU starts uploading the 

language files and a ‘System 
Upgrade Status’ window opens 
up. 

 
42. When the language files are 

uploaded the ‘System Upgrade 
Status’ window displays 
‘Upgrade complete’.  

Close the window. 

 



 

 

43. The units will reset and appear 
as Lost. 

When the units come up again 
the units will appear as Active 
and the system status 
indicators will show status ‘OK’ 
if all the language files were 
uploaded to all units. 

 

Delete language file(s)  
44. Change the FUU to the 

Advanced FUU Layout in Setup 
-> Advanced FUU Layout. 

 



 

 

45. Extra buttons appears in the 
FUU. 

 
46. Select the DC 6990 P(s) on the 

unit list that needs to have 
some language files deleted by 
using the ‘Select unit type’ or 
‘Select unit’ button. 

Press ‘Upgrade Languages’. 

 
47. An ‘Upgrade Languages on 

Units’ window opens up. 

Select the ‘Delete languages on 
DC 6990 P units’ tab. 

 



 

 

48. Select the languages to delete 
by manually selecting them or 
select them all by using the 
‘Select All’ button. 

Press the ‘Delete Languages on 
Units’ button. 

 
49. Confirm that you want to delete 

the languages by selecting the 
‘Continue’ button. 

 
50. The FUU starts deleting the 

language files and a ‘System 
Upgrade Status’ window opens 
up. 

 



 

 

51. When the language files have 
been deleted the ‘System 
Upgrade Status’ window 
displays ‘Upgrade complete’.  

Close the window. 

 
52. The units will reset and appear 

as Lost. 

When the units come up again 
the units will appear as Active 
and the system status 
indicators will show status 
‘Language Upgrade Needed’ if 
some/all the language files 
were deleted on the units. 

 

Open Language Library 
53. Open Library -> Edit Language 

Library. 

The FUU language library is 
automatically created when the 
FUU is opened the first time. 

The location of the language 
library can be seen from the 
path below the ‘FUU Language 
Library’ heading.  



 

 

54. To change the language library 
open Language/Select 
Language Library. 

 
55. A file browser window opens 

up. 

Browse for the language library 
to open, select it and press 
‘Open’. 

 
56. A new language library is now 

loaded with all its associated 
language files. 

Open Library -> Edit Language 
Library to view the available 
language files. 

 

 
  



 

 

Enable new languages 
When new language files have been uploaded to 
the DC 6990 P’s it is also necessary to enable 
these languages on the units. 

This has only to be done on one DC 6990 P 
regardless of the unit type. The last DC 6990 P in 
the system to change the language setup will 
determine the system configuration.  

57. Access the Main screen or any other screen with the 
scroll bar on a DC 6990 P. 

Open the ‘Setup’ menu by pressing the scroll down 
button and the left push button at the same time. 

 
58. The ‘Setup’ menu appears on the unit. 

Select the ‘Languages’ menu. 

 
59. Enable the languages to be shown on the DC 6990 P by 

pressing ‘Enable Lang’ for the required languages. 

 
60. The selected languages turn red when enabled. 

If there is more than one language enabled, the user will 
be prompted with a language selection page at next 
login. 

If there is only one language enabled, the user will not 
be prompted with a language selection but merely login 
in the selected language. 

 



 

 

 
61. Exit the ‘Languages’ menu  

Enter the Menu overview by pressing ‘Back’ twice.  

 

 
62. Enter the Menu overview 

Select the ‘Logout’ menu and confirm the logout. 

 

 



 

 

 
63. Login and select the login language.  

Please notice that if there is only one language enabled, 
the user will not be prompted with a language selection 
option! 

 

 
64. The unit now displays all static labels in the chosen login 

language. 

 
65. Save the CU/CCU configuration to keep the language 

selection next time the system starts up. 
 

 
  



 

 

Enable dynamic text 
The last step of enabling languages on the DC 6990 P’s is to enable the use of dynamic text from the SW 
6000. 

66. Open the CAA and create a the 
required language in 
‘CAA/Setup/Language/ 
Languages’. 

 
67. Translate all the labels for the 

new language in 
CAA/Setup/Language/Labels. 

 



 

 

68. Open the 
‘CAA/Setup/Language/DC69 
Language’ and select the 
language of the dynamic text 
to be shown on the DC 6990 
P’s in the ‘Language used by 
DC69 units’ drop-down list. 

 
69. Create a conference in the 

default language.  

Select the language in the tab 
in ‘Details’ 

Translate the conference 
information into the new 
language on the new language 
tab.  

Enable ‘Language in Use’. 

 



 

 

70. Create an agenda in the 
default language. Translate the 
agenda into the new language 
on the new language tab. 

 

 
71. Start the conference and set a 

subject on the agenda. All the 
dynamic text from SW 6000 
(conference name, agenda, set 
agenda subject, names etc.) is 
now available on the DC 6990 
Ps in the language set in the 
CAA. 

 

 
 

  



 

 

 

 

Changing of start image to DC 6990 P 
The start image on the DC 6990 P can be changed individually on all DC 6990 P units to customise the 
look of the units. 

Upload a start image 
72. Change the FUU to the 

Advanced FUU Layout in Setup 
-> Advanced FUU Layout. 

 
73. Extra buttons appears in the 

FUU. 

 



 

 

74. Select the DC 6990 P(s) on the 
unit list that needs to have a 
new start image uploaded by 
using the ‘Select unit type’ or 
‘Select unit’ button. 

Press ‘DC69 Start Image’. 

 
75. A ‘DC69 Start Image’ window 

opens up. 

Select Image Type 

Select the browse button ‘…’ to 
select the start image. 

 



 

 

76. A file browser window opens 
up. 

Browse for the image to 
upload, select it and press 
‘Open’. 

Please notice the image format 
must be .png with a resolution 
of 320x240 pixels. 

The free-ware program GIMP 
can be downloaded at 
www.gimp.org and used for 
making start images with the 
correct resolution. 

 
77. The selected image is now 

displayed in the ‘DC69 Start 
Image’ window. 

Select ‘Send Image to units’ to 
upload the start image to the 
selected DC 6990 P units. 

 
78. The FUU starts uploading the 

image. 

 

http://www.gimp.org/


 

 

79. When FUU is done uploading 
the image, an ‘Upgrade 
complete’ message is displayed 
and the ‘System Upgrade 
Status’ window can be closed. 

 

Delete a start image 
80. Change the FUU to the 

Advanced FUU Layout in Setup 
-> Advanced FUU Layout. 

 



 

 

81. Extra buttons appears in the 
FUU. 

 
82. Select the DC 6990 P(s) on the 

unit list that needs to have the 
start image deleted by using 
the ‘Select unit type’ or ‘Select 
unit’ button. 

Press ‘DC69 Start Image’. 

 



 

 

83. Select the ‘Delete Image from 
DC69 units’ tab. 

 
84. Select the ‘Delete Image from 

units’ button. The start image 
on all the selected DC 6990 P 
units will now be deleted and 
the ‘DC69 Start Image’ window 
will close automatically.  
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